Monthly Archives: April 2015

PowerShell ISE on Windows 10 (10049 preview)

Just a quick tip how to get to the PowerShell ISE in Windows 10 which they (MS) seems to be trying to hide away… 🙂

Launch the normal PowerShell command window – “All Apps – Windows System – Windows PowerShell”. Once it is running pin it to the taskbar. Now if you right click on the pinned icon it will include a menu option under Tasks for ‘Run ISE as Administrator’ and ‘Windows PowerShell ISE’.

You can then launch the ISE and pin that to the taskbar as well if you like…

 

Upgrading Windows 10 from 10041 to 10049 issues

I’ve been running a copy of Windows 10 (build 10041) in a VirtualBox VM and had major problems trying to update it to build 10049 (yes on the fast track). Other than the fact that the update/install takes extremely long it also seems to get stuck at 30% – after having being running for more than 24 hours already! I tried multiple times and each time it got stuck at the same time.

So I ventured out on that thing the Internet and found possible related posts of other people having similar issues (on VMWare or even physical installs) – all complaining about the 30% mark where things get stuck. One suggestion caught my eye – sorry, lost the original link to that but basically it suggests disconnecting the network (or pulling the network cable on physical install) just after the update download finished. Additionally some VMWare people suggested removing their VMWare client tools.

So I tried the same on my VirtualBox install. First I uninstalled the VirtualBox client tools. Then I started the install (download). Once the download finished (again…) I disconnected the network (unticked ‘Cable Connected’) and whoa! The install jumped to 30% almost straight away, stayed there for a minute or two (almost made me think this is all for nothing..) and then the progress bar started moving again. Another reboot around 75% and then all were done! Wow!

Well, at least now I’m ‘back’ at build 10049 waiting for the next one (10051)…